CVE-2010-2311 does not exist.