CVE-2020-1720

Current Description

A flaw was found in PostgreSQL's "ALTER ... DEPENDS ON EXTENSION", where sub-commands did not perform authorization checks. An authenticated attacker could use this flaw in certain configurations to perform drop objects such as function, triggers, et al., leading to database corruption. This issue affects PostgreSQL versions before 12.2, before 11.7, before 10.12 and before 9.6.17.

Basic Data

PublishedMarch 17, 2020
Last ModifiedMarch 27, 2020
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-862
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:M/Au:S/C:N/I:P/A:N
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityMEDIUM
CVSS 2 - AuthenticationSINGLE
CVSS 2 - Confidentiality ImpactNONE
CVSS 2 - Availability ImpactNONE
CVSS 2 - Base Score3.5
SeverityLOW
Exploitability Score6.8
Impact Score2.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationPostgresqlPostgresql********9.69.6.17
    2.3ApplicationPostgresqlPostgresql********10.010.12
    2.3ApplicationPostgresqlPostgresql********11.011.7
    2.3ApplicationPostgresqlPostgresql********12.012.2
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationRedhatDecision Manager7.0*******
    2.3ApplicationRedhatSoftware Collections-*******
    2.3OSRedhatEnterprise Linux8.0*******
    2.3OSRedhatVirtualization4.0*******

Vulnerable Software List

VendorProductVersions
Redhat Enterprise Linux 8.0
Redhat Decision Manager 7.0
Redhat Software Collections -
Redhat Virtualization 4.0
Postgresql Postgresql *

References

NameSourceURLTags
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1720https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1720CONFIRMIssue Tracking Patch Third Party Advisory
https://www.postgresql.org/about/news/2011/https://www.postgresql.org/about/news/2011/MISCRelease Notes Vendor Advisory