CVE-2019-19034

Current Description

UniValue::read() in UniValue before 1.0.5 allow attackers to cause a denial of service (the class internal data reaches an inconsistent state) via input data that triggers an error.

Basic Data

PublishedMarch 21, 2020
Last ModifiedMarch 24, 2020
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-74
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:N/I:N/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactNONE
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score5.0
SeverityMEDIUM
Exploitability Score10.0
Impact Score2.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationBloqUnivalue********1.0.5

Vulnerable Software List

VendorProductVersions
Bloq Univalue *

References

NameSourceURLTags
https://github.com/jgarzik/univalue/compare/v1.0.4...v1.0.5https://github.com/jgarzik/univalue/compare/v1.0.4...v1.0.5MISCRelease Notes Third Party Advisory
https://github.com/jgarzik/univalue/pull/58https://github.com/jgarzik/univalue/pull/58MISCPatch Third Party Advisory