CVE-2019-18668

Current Description

An issue was discovered in the Currency Switcher addon before 2.11.2 for WooCommerce if a user provides a currency that was not added by the administrator. In this case, even though the currency does not exist, it will be selected, but a price amount will fall back to the default currency. This means that if an attacker provides a currency that does not exist and is worth less than this default, the attacker can eventually purchase an item for a significantly cheaper price.

Basic Data

PublishedNovember 02, 2019
Last ModifiedNovember 07, 2019
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-20
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:S/C:N/I:P/A:N
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationSINGLE
CVSS 2 - Confidentiality ImpactNONE
CVSS 2 - Availability ImpactNONE
CVSS 2 - Base Score4.0
SeverityMEDIUM
Exploitability Score8.0
Impact Score2.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationWpwhamCurrency Switcher For Woocommerce*****wordpress**2.11.2

Vulnerable Software List

VendorProductVersions
Wpwham Currency Switcher For Woocommerce *

References

NameSourceURLTags
https://wordpress.org/plugins/currency-switcher-woocommerce/#developershttps://wordpress.org/plugins/currency-switcher-woocommerce/#developersMISCRelease Notes Vendor Advisory
https://wpvulndb.com/vulnerabilities/9936https://wpvulndb.com/vulnerabilities/9936MISCThird Party Advisory
https://www.infigo.hr/en/critical-vulnerability-in-currency-switcher-for-woocommerce-n61https://www.infigo.hr/en/critical-vulnerability-in-currency-switcher-for-woocommerce-n61MISCThird Party Advisory