CVE-2019-18662

Current Description

An issue was discovered in YouPHPTube through 7.7. User input passed through the live_stream_code POST parameter to /plugin/LiveChat/getChat.json.php is not properly sanitized (in getFromChat in plugin/LiveChat/Objects/LiveChatObj.php) before being used to construct a SQL query. This can be exploited by malicious users to, e.g., read sensitive data from the database through in-band SQL Injection attacks. Successful exploitation of this vulnerability requires the Live Chat plugin to be enabled.

Basic Data

PublishedNovember 02, 2019
Last ModifiedDecember 04, 2019
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-89
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score7.5
SeverityHIGH
Exploitability Score10.0
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationYouphptubeYouphptube********7.7

Vulnerable Software List

VendorProductVersions
Youphptube Youphptube *

References

NameSourceURLTags
http://packetstormsecurity.com/files/155564/YouPHPTube-7.7-SQL-Injection.htmlhttp://packetstormsecurity.com/files/155564/YouPHPTube-7.7-SQL-Injection.htmlMISC
20191204 [KIS-2019-10] YouPHPTube <= 7.7 (getChat.json.php) SQL Injection Vulnerabilityhttp://seclists.org/fulldisclosure/2019/Dec/9FULLDISC
https://github.com/YouPHPTube/YouPHPTube/issues/2202https://github.com/YouPHPTube/YouPHPTube/issues/2202MISCPatch Third Party Advisory