CVE-2019-14892

Current Description

A flaw was discovered in jackson-databind in versions before 2.9.10, 2.8.11.5 and 2.6.7.3, where it would permit polymorphic deserialization of a malicious object using commons-configuration 1 and 2 JNDI classes. An attacker could use this flaw to execute arbitrary code.

Basic Data

PublishedMarch 02, 2020
Last ModifiedJuly 29, 2020
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-502
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score7.5
SeverityHIGH
Exploitability Score10.0
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationFasterxmlJackson-databind********2.6.72.6.7.3
    2.3ApplicationFasterxmlJackson-databind********2.8.02.8.11.5
    2.3ApplicationFasterxmlJackson-databind********2.9.02.9.10
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationRedhatDecision Manager7.0*******
    2.3ApplicationRedhatJboss Data Grid7.0.0*******
    2.3ApplicationRedhatJboss Enterprise Application Platform7.0*******
    2.3ApplicationRedhatJboss Fuse7.0.0*******
    2.3ApplicationRedhatOpenshift Container Platform4.3*******
    2.3ApplicationRedhatProcess Automation7.0*******

Vulnerable Software List

VendorProductVersions
Fasterxml Jackson-databind *
Redhat Jboss Data Grid 7.0.0
Redhat Jboss Enterprise Application Platform 7.0
Redhat Jboss Fuse 7.0.0
Redhat Process Automation 7.0
Redhat Decision Manager 7.0
Redhat Openshift Container Platform 4.3

References

NameSourceURLTags
RHSA-2020:0729https://access.redhat.com/errata/RHSA-2020:0729REDHAT
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14892https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14892CONFIRMIssue Tracking Patch Third Party Advisory
https://github.com/FasterXML/jackson-databind/issues/2462https://github.com/FasterXML/jackson-databind/issues/2462MISCThird Party Advisory
[bookkeeper-issues] 20200729 [GitHub] [bookkeeper] padma81 opened a new issue #2387: Security vulnerabilities in the apache/bookkeeper-4.9.2 imagehttps://lists.apache.org/thread.html/r1b103833cb5bc8466e24ff0ecc5e75b45a705334ab6a444e64e840a0@%3CisMLIST