CVE-2019-14846

Current Description

Ansible, all ansible_engine-2.x versions and ansible_engine-3.x up to ansible_engine-3.5, was logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.

Basic Data

PublishedOctober 08, 2019
Last ModifiedOctober 21, 2019
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-532
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:L/AC:L/Au:N/C:P/I:N/A:N
CVSS 2 - Access VectorLOCAL
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactNONE
CVSS 2 - Base Score2.1
SeverityLOW
Exploitability Score3.9
Impact Score2.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationRedhatAnsible Engine********2.02.8.5
    2.3ApplicationRedhatAnsible Tower********3.03.5.3

Vulnerable Software List

VendorProductVersions
Redhat Ansible Tower *
Redhat Ansible Engine *

References

NameSourceURLTags
openSUSE-SU-2020:0513http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.htmlSUSE
openSUSE-SU-2020:0523http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.htmlSUSE
RHSA-2019:3201https://access.redhat.com/errata/RHSA-2019:3201REDHAT
RHSA-2019:3202https://access.redhat.com/errata/RHSA-2019:3202REDHAT
RHSA-2019:3203https://access.redhat.com/errata/RHSA-2019:3203REDHAT
RHSA-2019:3207https://access.redhat.com/errata/RHSA-2019:3207REDHAT
RHSA-2020:0756https://access.redhat.com/errata/RHSA-2020:0756REDHAT
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14846https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14846CONFIRMIssue Tracking Third Party Advisory
https://github.com/ansible/ansible/pull/63366https://github.com/ansible/ansible/pull/63366CONFIRM
[debian-lts-announce] 20200505 [SECURITY] [DLA 2202-1] ansible security updatehttps://lists.debian.org/debian-lts-announce/2020/05/msg00005.htmlMLIST