CVE-2017-16921

Current Description

In OTRS 6.0.x up to and including 6.0.1, OTRS 5.0.x up to and including 5.0.24, and OTRS 4.0.x up to and including 4.0.26, an attacker who is logged into OTRS as an agent can manipulate form parameters (related to PGP) and execute arbitrary shell commands with the permissions of the OTRS or web server user.

Basic Data

PublishedDecember 08, 2017
Last ModifiedOctober 03, 2019
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-78
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:S/C:C/I:C/A:C
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationSINGLE
CVSS 2 - Confidentiality ImpactCOMPLETE
CVSS 2 - Availability ImpactCOMPLETE
CVSS 2 - Base Score9.0
SeverityHIGH
Exploitability Score8.0
Impact Score10.0
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

CVSS 3 - Version3.0
CVSS 3 - Vector StringCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3 - Attack VectorNETWORK
CVSS 3 - Attack ComplexityLOW
CVSS 3 - Privileges RequiredLOW
CVSS 3 - User InteractionNONE
CVSS 3 - ScopeUNCHANGED
CVSS 3 - Confidentiality ImpactHIGH
CVSS 3 - Integrity ImpactHIGH
CVSS 3 - Availability ImpactHIGH
CVSS 3 - Base Score8.8
CVSS 3 - Base SeverityHIGH
Exploitability Score2.8
Base SeverityHIGH

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationOtrsOtrs4.0.1*******
    2.3ApplicationOtrsOtrs4.0.2*******
    2.3ApplicationOtrsOtrs4.0.3*******
    2.3ApplicationOtrsOtrs4.0.4*******
    2.3ApplicationOtrsOtrs4.0.5*******
    2.3ApplicationOtrsOtrs4.0.6*******
    2.3ApplicationOtrsOtrs4.0.7*******
    2.3ApplicationOtrsOtrs4.0.8*******
    2.3ApplicationOtrsOtrs4.0.9*******
    2.3ApplicationOtrsOtrs4.0.10*******
    2.3ApplicationOtrsOtrs4.0.11*******
    2.3ApplicationOtrsOtrs4.0.12*******
    2.3ApplicationOtrsOtrs4.0.13*******
    2.3ApplicationOtrsOtrs4.0.14*******
    2.3ApplicationOtrsOtrs4.0.15*******
    2.3ApplicationOtrsOtrs4.0.16*******
    2.3ApplicationOtrsOtrs4.0.17*******
    2.3ApplicationOtrsOtrs4.0.18*******
    2.3ApplicationOtrsOtrs4.0.19*******
    2.3ApplicationOtrsOtrs4.0.20*******
    2.3ApplicationOtrsOtrs4.0.21*******
    2.3ApplicationOtrsOtrs4.0.22*******
    2.3ApplicationOtrsOtrs4.0.23*******
    2.3ApplicationOtrsOtrs4.0.24*******
    2.3ApplicationOtrsOtrs4.0.25*******
    2.3ApplicationOtrsOtrs4.0.26*******
    2.3ApplicationOtrsOtrs5.0.0*******
    2.3ApplicationOtrsOtrs5.0.0alpha1******
    2.3ApplicationOtrsOtrs5.0.0beta1******
    2.3ApplicationOtrsOtrs5.0.0beta2******
    2.3ApplicationOtrsOtrs5.0.0beta3******
    2.3ApplicationOtrsOtrs5.0.0beta4******
    2.3ApplicationOtrsOtrs5.0.0beta5******
    2.3ApplicationOtrsOtrs5.0.0rc1******
    2.3ApplicationOtrsOtrs5.0.1*******
    2.3ApplicationOtrsOtrs5.0.2*******
    2.3ApplicationOtrsOtrs5.0.3*******
    2.3ApplicationOtrsOtrs5.0.4*******
    2.3ApplicationOtrsOtrs5.0.5*******
    2.3ApplicationOtrsOtrs5.0.6*******
    2.3ApplicationOtrsOtrs5.0.7*******
    2.3ApplicationOtrsOtrs5.0.8*******
    2.3ApplicationOtrsOtrs5.0.9*******
    2.3ApplicationOtrsOtrs5.0.10*******
    2.3ApplicationOtrsOtrs5.0.11*******
    2.3ApplicationOtrsOtrs5.0.12*******
    2.3ApplicationOtrsOtrs5.0.13*******
    2.3ApplicationOtrsOtrs5.0.14*******
    2.3ApplicationOtrsOtrs5.0.15*******
    2.3ApplicationOtrsOtrs5.0.16*******
    2.3ApplicationOtrsOtrs5.0.17*******
    2.3ApplicationOtrsOtrs5.0.18*******
    2.3ApplicationOtrsOtrs5.0.19*******
    2.3ApplicationOtrsOtrs5.0.20*******
    2.3ApplicationOtrsOtrs5.0.21*******
    2.3ApplicationOtrsOtrs5.0.22*******
    2.3ApplicationOtrsOtrs5.0.23*******
    2.3ApplicationOtrsOtrs5.0.24*******
    2.3ApplicationOtrsOtrs6.0.0*******
    2.3ApplicationOtrsOtrs6.0.0alpha1******
    2.3ApplicationOtrsOtrs6.0.0beta1******
    2.3ApplicationOtrsOtrs6.0.0beta2******
    2.3ApplicationOtrsOtrs6.0.0beta3******
    2.3ApplicationOtrsOtrs6.0.0beta4******
    2.3ApplicationOtrsOtrs6.0.0beta5******
    2.3ApplicationOtrsOtrs6.0.0rc1******
    2.3ApplicationOtrsOtrs6.0.1*******
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3OSDebianDebian Linux7.0*******
    2.3OSDebianDebian Linux8.0*******
    2.3OSDebianDebian Linux9.0*******

Vulnerable Software List

VendorProductVersions
Debian Debian Linux 7.0, 8.0, 9.0
Otrs Otrs 4.0.1, 4.0.10, 4.0.11, 4.0.12, 4.0.13, 4.0.14, 4.0.15, 4.0.16, 4.0.17, 4.0.18, 4.0.19, 4.0.2, 4.0.20, 4.0.21, 4.0.22, 4.0.23, 4.0.24, 4.0.25, 4.0.26, 4.0.3, 4.0.4, 4.0.5, 4.0.6, 4.0.7, 4.0.8, 4.0.9, 5.0.0, 5.0.1, 5.0.10, 5.0.11, 5.0.12, 5.0.13, 5.0.14, 5.0.15, 5.0.16, 5.0.17, 5.0.18, 5.0.19, 5.0.2, 5.0.20, 5.0.21, 5.0.22, 5.0.23, 5.0.24, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 5.0.8, 5.0.9, 6.0.0, 6.0.1

References

NameSourceURLTags
[debian-lts-announce] 20171219 [SECURITY] [DLA 1212-1] otrs2 security updatehttps://lists.debian.org/debian-lts-announce/2017/12/msg00015.htmlMLISTMailing List Third Party Advisory
DSA-4066https://www.debian.org/security/2017/dsa-4066DEBIANMailing List Third Party Advisory
43853https://www.exploit-db.com/exploits/43853/EXPLOIT-DBExploit Third Party Advisory VDB Entry
https://www.otrs.com/security-advisory-2017-09-security-update-otrs-framework/https://www.otrs.com/security-advisory-2017-09-security-update-otrs-framework/CONFIRMIssue Tracking Patch Vendor Advisory