CVE-2014-8114

Current Description

The UberFire Framework 0.3.x does not properly restrict paths, which allows remote attackers to (1) execute arbitrary code by uploading crafted content to FileUploadServlet or (2) read arbitrary files via vectors involving FileDownloadServlet.

Basic Data

PublishedFebruary 20, 2015
Last ModifiedApril 12, 2019
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-264
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:M/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityMEDIUM
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score6.8
SeverityMEDIUM
Exploitability Score8.6
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationRedhatUberfire0.3.0*******
    2.3ApplicationRedhatUberfire0.3.1*******
    2.3ApplicationRedhatUberfire0.3.2*******
    2.3ApplicationRedhatUberfire0.3.3*******

Vulnerable Software List

VendorProductVersions
Redhat Uberfire 0.3.0, 0.3.1, 0.3.2, 0.3.3

References

NameSourceURLTags
RHSA-2015:0234http://rhn.redhat.com/errata/RHSA-2015-0234.htmlREDHATVendor Advisory
RHSA-2015:0235http://rhn.redhat.com/errata/RHSA-2015-0235.htmlREDHATVendor Advisory
88199http://www.securityfocus.com/bid/88199BID
https://github.com/uberfire/uberfire/commit/21ec50eb15https://github.com/uberfire/uberfire/commit/21ec50eb15CONFIRM