CVE-2014-6170

Current Description

The HTTPInput node in IBM WebSphere Message Broker 7.0 before 7.0.0.8 and 8.0 before 8.0.0.6 and IBM Integration Bus 9.0 before 9.0.0.4 allows remote attackers to obtain sensitive information by triggering a SOAP fault.

Basic Data

PublishedFebruary 02, 2015
Last ModifiedSeptember 08, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-200
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:P/I:N/A:N
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactNONE
CVSS 2 - Base Score5.0
SeverityMEDIUM
Exploitability Score10.0
Impact Score2.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationIbmIntegration Bus9.0*******
    2.3ApplicationIbmIntegration Bus9.0.0.1*******
    2.3ApplicationIbmIntegration Bus9.0.0.2*******
    2.3ApplicationIbmIntegration Bus9.0.0.3*******
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationIbmWebsphere Message Broker7.0.*******
    2.3ApplicationIbmWebsphere Message Broker7.0.0.1*******
    2.3ApplicationIbmWebsphere Message Broker7.0.0.2*******
    2.3ApplicationIbmWebsphere Message Broker7.0.0.3*******
    2.3ApplicationIbmWebsphere Message Broker7.0.0.4*******
    2.3ApplicationIbmWebsphere Message Broker7.0.0.5*******
    2.3ApplicationIbmWebsphere Message Broker7.0.0.6*******
    2.3ApplicationIbmWebsphere Message Broker7.0.0.7*******
    2.3ApplicationIbmWebsphere Message Broker8.0*******
    2.3ApplicationIbmWebsphere Message Broker8.0.0.1*******
    2.3ApplicationIbmWebsphere Message Broker8.0.0.2*******
    2.3ApplicationIbmWebsphere Message Broker8.0.0.3*******
    2.3ApplicationIbmWebsphere Message Broker8.0.0.4*******
    2.3ApplicationIbmWebsphere Message Broker8.0.0.5*******

Vulnerable Software List

VendorProductVersions
Ibm Integration Bus 9.0, 9.0.0.1, 9.0.0.2, 9.0.0.3
Ibm Websphere Message Broker 7.0., 7.0.0.1, 7.0.0.2, 7.0.0.3, 7.0.0.4, 7.0.0.5, 7.0.0.6, 7.0.0.7, 8.0, 8.0.0.1, 8.0.0.2, 8.0.0.3, 8.0.0.4, 8.0.0.5

References

NameSourceURLTags
IT01929http://www-01.ibm.com/support/docview.wss?uid=swg1IT01929AIXAPAR
http://www-01.ibm.com/support/docview.wss?uid=swg21690725http://www-01.ibm.com/support/docview.wss?uid=swg21690725CONFIRMVendor Advisory
ibm-wmb-cve20146170-info-disc(98309)https://exchange.xforce.ibmcloud.com/vulnerabilities/98309XF