CVE-2014-3612

Current Description

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows remote attackers to bypass authentication by logging in with an empty password and valid username, which triggers an unauthenticated bind. NOTE: this identifier has been SPLIT per ADT2 due to different vulnerability types. See CVE-2015-6524 for the use of wildcard operators in usernames.

Referenced by CVEs:CVE-2015-6524

Basic Data

PublishedAugust 24, 2015
Last ModifiedMarch 27, 2019
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-287
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score7.5
SeverityHIGH
Exploitability Score10.0
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationApacheActivemq5.0.0*******
    2.3ApplicationApacheActivemq5.1.0*******
    2.3ApplicationApacheActivemq5.2.0*******
    2.3ApplicationApacheActivemq5.3.0*******
    2.3ApplicationApacheActivemq5.3.1*******
    2.3ApplicationApacheActivemq5.3.2*******
    2.3ApplicationApacheActivemq5.4.0*******
    2.3ApplicationApacheActivemq5.4.1*******
    2.3ApplicationApacheActivemq5.4.2*******
    2.3ApplicationApacheActivemq5.4.3*******
    2.3ApplicationApacheActivemq5.5.0*******
    2.3ApplicationApacheActivemq5.5.1*******
    2.3ApplicationApacheActivemq5.6.0*******
    2.3ApplicationApacheActivemq5.7.0*******
    2.3ApplicationApacheActivemq5.8.0*******
    2.3ApplicationApacheActivemq5.9.0*******
    2.3ApplicationApacheActivemq5.9.1*******
    2.3ApplicationApacheActivemq5.10.0*******

Vulnerable Software List

VendorProductVersions
Apache Activemq 5.0.0, 5.1.0, 5.10.0, 5.2.0, 5.3.0, 5.3.1, 5.3.2, 5.4.0, 5.4.1, 5.4.2, 5.4.3, 5.5.0, 5.5.1, 5.6.0, 5.7.0, 5.8.0, 5.9.0, 5.9.1

References

NameSourceURLTags
http://activemq.apache.org/security-advisories.data/CVE-2014-3612-announcement.txthttp://activemq.apache.org/security-advisories.data/CVE-2014-3612-announcement.txtCONFIRMVendor Advisory
RHSA-2015:0137http://rhn.redhat.com/errata/RHSA-2015-0137.htmlREDHAT
RHSA-2015:0138http://rhn.redhat.com/errata/RHSA-2015-0138.htmlREDHAT
[oss-security] 20150205 [ANNOUNCE] CVE-2014-3600, CVE-2014-3612 and CVE-2014-8110 - Apache ActiveMQ vulnerabilitieshttp://seclists.org/oss-sec/2015/q1/427MLIST
72513http://www.securityfocus.com/bid/72513BID
[activemq-commits] 20190327 svn commit: r1042639 - in /websites/production/activemq/content/activemq-website: ./ projects/artemis/download/ projects/classic/download/ projects/cms/download/ security-advisories.data/https://lists.apache.org/thread.html/a859563f05fbe7c31916b3178c2697165bd9bbf5a65d1cf62aef27d2@%3CcomMLIST