CVE-2011-1688

Current Description

Directory traversal vulnerability in Best Practical Solutions RT 3.2.0 through 3.6.10, 3.8.0 through 3.8.9, and 4.0.0rc through 4.0.0rc7 allows remote attackers to read arbitrary files via a crafted HTTP request.

Basic Data

PublishedApril 22, 2011
Last ModifiedAugust 17, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-22
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:M/Au:N/C:P/I:N/A:N
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityMEDIUM
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactNONE
CVSS 2 - Base Score4.3
SeverityMEDIUM
Exploitability Score8.6
Impact Score2.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationBestpracticalRt3.2.0*******
    2.3ApplicationBestpracticalRt3.2.1*******
    2.3ApplicationBestpracticalRt3.2.2*******
    2.3ApplicationBestpracticalRt3.2.3*******
    2.3ApplicationBestpracticalRt3.4.0*******
    2.3ApplicationBestpracticalRt3.4.1*******
    2.3ApplicationBestpracticalRt3.4.2*******
    2.3ApplicationBestpracticalRt3.4.3*******
    2.3ApplicationBestpracticalRt3.4.4*******
    2.3ApplicationBestpracticalRt3.4.5*******
    2.3ApplicationBestpracticalRt3.4.6*******
    2.3ApplicationBestpracticalRt3.6.0*******
    2.3ApplicationBestpracticalRt3.6.1*******
    2.3ApplicationBestpracticalRt3.6.2*******
    2.3ApplicationBestpracticalRt3.6.3*******
    2.3ApplicationBestpracticalRt3.6.4*******
    2.3ApplicationBestpracticalRt3.6.5*******
    2.3ApplicationBestpracticalRt3.6.6*******
    2.3ApplicationBestpracticalRt3.6.7*******
    2.3ApplicationBestpracticalRt3.6.8*******
    2.3ApplicationBestpracticalRt3.6.9*******
    2.3ApplicationBestpracticalRt3.6.10*******
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationBestpracticalRt3.8.0*******
    2.3ApplicationBestpracticalRt3.8.1*******
    2.3ApplicationBestpracticalRt3.8.2*******
    2.3ApplicationBestpracticalRt3.8.3*******
    2.3ApplicationBestpracticalRt3.8.4*******
    2.3ApplicationBestpracticalRt3.8.5*******
    2.3ApplicationBestpracticalRt3.8.6*******
    2.3ApplicationBestpracticalRt3.8.6rc1******
    2.3ApplicationBestpracticalRt3.8.7*******
    2.3ApplicationBestpracticalRt3.8.7rc1******
    2.3ApplicationBestpracticalRt3.8.8*******
    2.3ApplicationBestpracticalRt3.8.8rc2******
    2.3ApplicationBestpracticalRt3.8.8rc3******
    2.3ApplicationBestpracticalRt3.8.8rc4******
    2.3ApplicationBestpracticalRt3.8.9*******
    2.3ApplicationBestpracticalRt3.8.9rc1******
    2.3ApplicationBestpracticalRt3.8.9rc2******
    2.3ApplicationBestpracticalRt3.8.9rc3******
  • OR - Configuration 3
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationBestpracticalRt4.0.0rc1******
    2.3ApplicationBestpracticalRt4.0.0rc2******
    2.3ApplicationBestpracticalRt4.0.0rc3******
    2.3ApplicationBestpracticalRt4.0.0rc4******
    2.3ApplicationBestpracticalRt4.0.0rc5******
    2.3ApplicationBestpracticalRt4.0.0rc6******
    2.3ApplicationBestpracticalRt4.0.0rc7******

Vulnerable Software List

VendorProductVersions
Bestpractical Rt 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.6, 3.6.0, 3.6.1, 3.6.10, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.6.6, 3.6.7, 3.6.8, 3.6.9, 3.8.0, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.8.5, 3.8.6, 3.8.7, 3.8.8, 3.8.9, 4.0.0

References

NameSourceURLTags
http://blog.bestpractical.com/2011/04/security-vulnerabilities-in-rt.htmlhttp://blog.bestpractical.com/2011/04/security-vulnerabilities-in-rt.htmlCONFIRM
[rt-announce] 20110414 Security vulnerabilities in RThttp://lists.bestpractical.com/pipermail/rt-announce/2011-April/000187.htmlMLISTPatch
[rt-announce] 20110414 RT 3.8.10 Released - Security Releasehttp://lists.bestpractical.com/pipermail/rt-announce/2011-April/000188.htmlMLISTPatch
[rt-announce] 20110414 RT 3.6.11 Released - Security Releasehttp://lists.bestpractical.com/pipermail/rt-announce/2011-April/000189.htmlMLISTPatch
44189http://secunia.com/advisories/44189SECUNIAVendor Advisory
DSA-2220http://www.debian.org/security/2011/dsa-2220DEBIAN
47383http://www.securityfocus.com/bid/47383BID
ADV-2011-1071http://www.vupen.com/english/advisories/2011/1071VUPEN
https://bugzilla.redhat.com/show_bug.cgi?id=696795https://bugzilla.redhat.com/show_bug.cgi?id=696795CONFIRMPatch
rt-unspecified-dir-traversal(66795)https://exchange.xforce.ibmcloud.com/vulnerabilities/66795XF