CVE-2011-1685

Current Description

Best Practical Solutions RT 3.8.0 through 3.8.9 and 4.0.0rc through 4.0.0rc7, when the CustomFieldValuesSources (aka external custom field) option is enabled, allows remote authenticated users to execute arbitrary code via unspecified vectors, as demonstrated by a cross-site request forgery (CSRF) attack.

Basic Data

PublishedApril 22, 2011
Last ModifiedAugust 17, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-352
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:H/Au:S/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityHIGH
CVSS 2 - AuthenticationSINGLE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score4.6
SeverityMEDIUM
Exploitability Score3.9
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationBestpracticalRt3.8.0*******
    2.3ApplicationBestpracticalRt3.8.1*******
    2.3ApplicationBestpracticalRt3.8.2*******
    2.3ApplicationBestpracticalRt3.8.3*******
    2.3ApplicationBestpracticalRt3.8.4*******
    2.3ApplicationBestpracticalRt3.8.5*******
    2.3ApplicationBestpracticalRt3.8.6*******
    2.3ApplicationBestpracticalRt3.8.6rc1******
    2.3ApplicationBestpracticalRt3.8.7*******
    2.3ApplicationBestpracticalRt3.8.7rc1******
    2.3ApplicationBestpracticalRt3.8.8*******
    2.3ApplicationBestpracticalRt3.8.8rc2******
    2.3ApplicationBestpracticalRt3.8.8rc3******
    2.3ApplicationBestpracticalRt3.8.8rc4******
    2.3ApplicationBestpracticalRt3.8.9*******
    2.3ApplicationBestpracticalRt3.8.9rc1******
    2.3ApplicationBestpracticalRt3.8.9rc2******
    2.3ApplicationBestpracticalRt3.8.9rc3******
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationBestpracticalRt4.0.0rc1******
    2.3ApplicationBestpracticalRt4.0.0rc2******
    2.3ApplicationBestpracticalRt4.0.0rc3******
    2.3ApplicationBestpracticalRt4.0.0rc4******
    2.3ApplicationBestpracticalRt4.0.0rc5******
    2.3ApplicationBestpracticalRt4.0.0rc6******
    2.3ApplicationBestpracticalRt4.0.0rc7******

Vulnerable Software List

VendorProductVersions
Bestpractical Rt 3.8.0, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.8.5, 3.8.6, 3.8.7, 3.8.8, 3.8.9, 4.0.0

References

NameSourceURLTags
http://blog.bestpractical.com/2011/04/security-vulnerabilities-in-rt.htmlhttp://blog.bestpractical.com/2011/04/security-vulnerabilities-in-rt.htmlCONFIRMVendor Advisory
[rt-announce] 20110414 Security vulnerabilities in RThttp://lists.bestpractical.com/pipermail/rt-announce/2011-April/000187.htmlMLISTPatch
[rt-announce] 20110414 RT 3.8.10 Released - Security Releasehttp://lists.bestpractical.com/pipermail/rt-announce/2011-April/000188.htmlMLISTPatch
44189http://secunia.com/advisories/44189SECUNIAVendor Advisory
DSA-2220http://www.debian.org/security/2011/dsa-2220DEBIAN
47383http://www.securityfocus.com/bid/47383BID
ADV-2011-1071http://www.vupen.com/english/advisories/2011/1071VUPEN
https://bugzilla.redhat.com/show_bug.cgi?id=696795https://bugzilla.redhat.com/show_bug.cgi?id=696795CONFIRMPatch
rt-externalcustomfield-code-exec(66791)https://exchange.xforce.ibmcloud.com/vulnerabilities/66791XF