CVE-2011-1572

Current Description

Directory traversal vulnerability in the Admin Defined Commands (ADC) feature in gitolite before 1.5.9.1 allows remote attackers to execute arbitrary commands via .. (dot dot) sequences in admin-defined commands.

Basic Data

PublishedOctober 04, 2011
Last ModifiedSeptember 09, 2019
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-22
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:M/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityMEDIUM
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score6.8
SeverityMEDIUM
Exploitability Score8.6
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationGitoliteGitolite0.50*******
    2.3ApplicationGitoliteGitolite0.55*******
    2.3ApplicationGitoliteGitolite0.60*******
    2.3ApplicationGitoliteGitolite0.65*******
    2.3ApplicationGitoliteGitolite0.70*******
    2.3ApplicationGitoliteGitolite0.80*******
    2.3ApplicationGitoliteGitolite0.85*******
    2.3ApplicationGitoliteGitolite0.90*******
    2.3ApplicationGitoliteGitolite0.95*******
    2.3ApplicationGitoliteGitolite1.0*******
    2.3ApplicationGitoliteGitolite1.0rc1******
    2.3ApplicationGitoliteGitolite1.1*******
    2.3ApplicationGitoliteGitolite1.2*******
    2.3ApplicationGitoliteGitolite1.3*******
    2.3ApplicationGitoliteGitolite1.4*******
    2.3ApplicationGitoliteGitolite1.4.1*******
    2.3ApplicationGitoliteGitolite1.4.2*******
    2.3ApplicationGitoliteGitolite1.5*******
    2.3ApplicationGitoliteGitolite1.5.1*******
    2.3ApplicationGitoliteGitolite1.5.2*******
    2.3ApplicationGitoliteGitolite1.5.3*******
    2.3ApplicationGitoliteGitolite1.5.4*******
    2.3ApplicationGitoliteGitolite1.5.5*******
    2.3ApplicationGitoliteGitolite1.5.6*******
    2.3ApplicationGitoliteGitolite1.5.7*******
    2.3ApplicationGitoliteGitolite1.5.8*******
    2.3ApplicationGitoliteGitolite********1.5.9

Vulnerable Software List

VendorProductVersions
Gitolite Gitolite *, 0.50, 0.55, 0.60, 0.65, 0.70, 0.80, 0.85, 0.90, 0.95, 1.0, 1.1, 1.2, 1.3, 1.4, 1.4.1, 1.4.2, 1.5, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 1.5.7, 1.5.8

References

NameSourceURLTags
http://groups.google.com/group/gitolite/browse_thread/thread/797a93ec26e1dcbc?pli=1http://groups.google.com/group/gitolite/browse_thread/thread/797a93ec26e1dcbc?pli=1CONFIRM
[oss-security] 20110409 CVE id request: gitolitehttp://seclists.org/oss-sec/2011/q2/197MLISTPatch
[oss-security] 20110411 Re: CVE id request: gitolitehttp://seclists.org/oss-sec/2011/q2/209MLISTPatch
DSA-2215http://www.debian.org/security/2011/dsa-2215DEBIAN
46473http://www.securityfocus.com/bid/46473BIDPatch
https://bugzilla.redhat.com/show_bug.cgi?id=695568https://bugzilla.redhat.com/show_bug.cgi?id=695568CONFIRMPatch
gitolite-adc-security-bypass(65542)https://exchange.xforce.ibmcloud.com/vulnerabilities/65542XF
https://github.com/sitaramc/gitolite/commit/4ce00aef84d1ff7c35f7adbbb99a6241cfda00cchttps://github.com/sitaramc/gitolite/commit/4ce00aef84d1ff7c35f7adbbb99a6241cfda00ccCONFIRMPatch