CVE-2011-1522

Current Description

Multiple SQL injection vulnerabilities in the DoctrineDBALPlatformsAbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.

Basic Data

PublishedMay 03, 2011
Last ModifiedMay 31, 2011
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-89
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score7.5
SeverityHIGH
Exploitability Score10.0
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationDoctrine-projectDoctrine1.2.0********
    2.3ApplicationDoctrine-projectDoctrine1.2.1********
    2.3ApplicationDoctrine-projectDoctrine1.2.2********
    2.3ApplicationDoctrine-projectDoctrine1.2.3********
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationDoctrine-projectDoctrine2.0.0*******
    2.3ApplicationDoctrine-projectDoctrine2.0.0alpha1******
    2.3ApplicationDoctrine-projectDoctrine2.0.0alpha2******
    2.3ApplicationDoctrine-projectDoctrine2.0.0alpha3******
    2.3ApplicationDoctrine-projectDoctrine2.0.0alpha4******
    2.3ApplicationDoctrine-projectDoctrine2.0.0beta1******
    2.3ApplicationDoctrine-projectDoctrine2.0.0beta2******
    2.3ApplicationDoctrine-projectDoctrine2.0.0beta3******
    2.3ApplicationDoctrine-projectDoctrine2.0.0beta4******
    2.3ApplicationDoctrine-projectDoctrine2.0.0rc1******
    2.3ApplicationDoctrine-projectDoctrine2.0.0rc2******
    2.3ApplicationDoctrine-projectDoctrine2.0.1*******
    2.3ApplicationDoctrine-projectDoctrine2.0.2*******

Vulnerable Software List

VendorProductVersions
Doctrine-project Doctrine1.2.0 *
Doctrine-project Doctrine1.2.1 *
Doctrine-project Doctrine1.2.2 *
Doctrine-project Doctrine1.2.3 *
Doctrine-project Doctrine 2.0.0, 2.0.1, 2.0.2

References

NameSourceURLTags
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622674http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622674CONFIRM
[oss-security] 20110325 CVE Request -- php-doctrine-Doctrine -- SQL injection flawhttp://openwall.com/lists/oss-security/2011/03/25/2MLIST
[oss-security] 20110328 Re: CVE Request -- php-doctrine-Doctrine -- SQL injection flawhttp://openwall.com/lists/oss-security/2011/03/28/3MLIST
DSA-2223http://www.debian.org/security/2011/dsa-2223DEBIAN
http://www.doctrine-project.org/blog/doctrine-security-fixhttp://www.doctrine-project.org/blog/doctrine-security-fixCONFIRMPatch Vendor Advisory
47034http://www.securityfocus.com/bid/47034BID
https://bugzilla.redhat.com/show_bug.cgi?id=689396https://bugzilla.redhat.com/show_bug.cgi?id=689396CONFIRMPatch