CVE-2011-1407

Current Description

The DKIM implementation in Exim 4.7x before 4.76 permits matching for DKIM identities to apply to lookup items, instead of only strings, which allows remote attackers to execute arbitrary code or access a filesystem via a crafted identity.

Basic Data

PublishedMay 16, 2011
Last ModifiedSeptember 07, 2011
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-20
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score7.5
SeverityHIGH
Exploitability Score10.0
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationEximExim4.70*******
    2.3ApplicationEximExim4.71*******
    2.3ApplicationEximExim4.72*******
    2.3ApplicationEximExim4.73*******
    2.3ApplicationEximExim4.74*******
    2.3ApplicationEximExim4.75*******

Vulnerable Software List

VendorProductVersions
Exim Exim 4.70, 4.71, 4.72, 4.73, 4.74, 4.75

References

NameSourceURLTags
DSA-2236http://www.debian.org/security/2011/dsa-2236DEBIAN
47836http://www.securityfocus.com/bid/47836BID
USN-1135-1http://www.ubuntu.com/usn/USN-1135-1UBUNTU
[exim-announce] 20110509 Exim 4.76 Releasehttps://lists.exim.org/lurker/message/20110509.091632.daed0206.en.htmlMLISTPatch
[exim-announce] 20110512 Exim 4.76 Release: updated impact assessmenthttps://lists.exim.org/lurker/message/20110512.102909.8136175a.en.htmlMLISTPatch