CVE-2011-1329

Current Description

WalRack 1.x before 1.1.9 and 2.x before 2.0.7 does not properly restrict file uploads, which allows remote attackers to execute arbitrary PHP code via vectors involving a double extension, as demonstrated by a .php.zzz file.

Referenced by CVEs:CVE-2011-2215

Basic Data

PublishedMay 31, 2011
Last ModifiedAugust 17, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-264
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:M/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityMEDIUM
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score6.8
SeverityMEDIUM
Exploitability Score8.6
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationWalrus DigitWalrack1.0.1*******
    2.3ApplicationWalrus DigitWalrack1.1.1*******
    2.3ApplicationWalrus DigitWalrack1.1.2*******
    2.3ApplicationWalrus DigitWalrack1.1.3*******
    2.3ApplicationWalrus DigitWalrack1.1.4*******
    2.3ApplicationWalrus DigitWalrack1.1.5*******
    2.3ApplicationWalrus DigitWalrack1.1.6*******
    2.3ApplicationWalrus DigitWalrack1.1.7*******
    2.3ApplicationWalrus DigitWalrack1.1.8*******
    2.3ApplicationWalrus DigitWalrack2.0.1*******
    2.3ApplicationWalrus DigitWalrack2.0.2*******
    2.3ApplicationWalrus DigitWalrack2.0.3*******
    2.3ApplicationWalrus DigitWalrack2.0.4*******
    2.3ApplicationWalrus DigitWalrack2.0.5*******
    2.3ApplicationWalrus DigitWalrack2.0.6*******

Vulnerable Software List

VendorProductVersions
Walrus Digit Walrack 1.0.1, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6

References

NameSourceURLTags
http://digit.que.ne.jp/work/index.cgi?WalRackhttp://digit.que.ne.jp/work/index.cgi?WalRackCONFIRMPatch
http://digit.que.ne.jp/work/index.cgi?WalRack2http://digit.que.ne.jp/work/index.cgi?WalRack2CONFIRMPatch
http://jvn.jp/en/jp/JVN46984044/54827/index.htmlhttp://jvn.jp/en/jp/JVN46984044/54827/index.htmlCONFIRM
JVN#46984044http://jvn.jp/en/jp/JVN46984044/index.htmlJVN
JVNDB-2011-000032http://jvndb.jvn.jp/jvndb/JVNDB-2011-000032JVNDB
48001http://www.securityfocus.com/bid/48001BID
walrack-uploaded-files-code-exec(67641)https://exchange.xforce.ibmcloud.com/vulnerabilities/67641XF