CVE-2008-2841

Current Description

Argument injection vulnerability in XChat 2.8.7b and earlier on Windows, when Internet Explorer is used, allows remote attackers to execute arbitrary commands via the --command parameter in an ircs:// URI.

Basic Data

PublishedJune 24, 2008
Last ModifiedSeptember 29, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-94
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:M/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityMEDIUM
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score6.8
SeverityMEDIUM
Exploitability Score8.6
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegetrue

Base Metric V3

No data provided.

Configurations

  • AND
    • OR - Configuration 1
      Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
      2.3OSMicrosoftWindows Nt********
    • OR Running on/with:
      Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
      2.3ApplicationMicrosoftIe********
      2.3ApplicationXchatXchat********2.8.7b

Vulnerable Software List

VendorProductVersions
Microsoft Ie *
Xchat Xchat *

References

NameSourceURLTags
http://forum.xchat.org/viewtopic.php?t=4218http://forum.xchat.org/viewtopic.php?t=4218CONFIRM
30695http://secunia.com/advisories/30695SECUNIAVendor Advisory
29696http://www.securityfocus.com/bid/29696BID
xchat-ircs-command-execution(43065)https://exchange.xforce.ibmcloud.com/vulnerabilities/43065XF
5795https://www.exploit-db.com/exploits/5795EXPLOIT-DB