CVE-2008-2696

Current Description

Exiv2 0.16 allows user-assisted remote attackers to cause a denial of service (divide-by-zero and application crash) via a zero value in Nikon lens information in the metadata of an image, related to "pretty printing" and the RationalValue::toLong function.

Basic Data

PublishedJune 13, 2008
Last ModifiedAugust 08, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-189
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:M/Au:N/C:N/I:N/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityMEDIUM
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactNONE
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score4.3
SeverityMEDIUM
Exploitability Score8.6
Impact Score2.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationExiv2Exiv20.16*******

Vulnerable Software List

VendorProductVersions
Exiv2 Exiv2 0.16

References

NameSourceURLTags
http://bugzilla.gnome.org/show_bug.cgi?id=524715http://bugzilla.gnome.org/show_bug.cgi?id=524715MISCExploit
http://dev.robotbattle.com/bugs/view.php?id=0000546http://dev.robotbattle.com/bugs/view.php?id=0000546MISC
SUSE-SR:2008:023http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00012.htmlSUSE
30519http://secunia.com/advisories/30519SECUNIAVendor Advisory
32273http://secunia.com/advisories/32273SECUNIA
http://www.exiv2.org/changelog.htmlhttp://www.exiv2.org/changelog.htmlCONFIRM
MDVSA-2008:119http://www.mandriva.com/security/advisories?name=MDVSA-2008:119MANDRIVA
29586http://www.securityfocus.com/bid/29586BID
USN-655-1http://www.ubuntu.com/usn/usn-655-1UBUNTU
ADV-2008-1766http://www.vupen.com/english/advisories/2008/1766/referencesVUPEN
exiv2-printing-dos(42885)https://exchange.xforce.ibmcloud.com/vulnerabilities/42885XF