CVE-2008-0217

Current Description

The script program in FreeBSD 5.0 through 7.0-PRERELEASE invokes openpty, which creates a pseudo-terminal with world-readable and world-writable permissions when it is not run as root, which allows local users to read data from the terminal of the user running script.

Basic Data

PublishedJanuary 16, 2008
Last ModifiedAugust 08, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-264
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:L/AC:M/Au:N/C:C/I:C/A:C
CVSS 2 - Access VectorLOCAL
CVSS 2 - Access ComplexityMEDIUM
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactCOMPLETE
CVSS 2 - Availability ImpactCOMPLETE
CVSS 2 - Base Score6.9
SeverityMEDIUM
Exploitability Score3.4
Impact Score10.0
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3OSFreebsdFreebsd5.0*******
    2.3OSFreebsdFreebsd5.5*******
    2.3OSFreebsdFreebsd6.0*******
    2.3OSFreebsdFreebsd6.1*******
    2.3OSFreebsdFreebsd6.2*******
    2.3OSFreebsdFreebsd7.0*******
    2.3OSFreebsdFreebsd7.0pre-release******

Vulnerable Software List

VendorProductVersions
Freebsd Freebsd 5.0, 5.5, 6.0, 6.1, 6.2, 7.0

References

NameSourceURLTags
28498http://secunia.com/advisories/28498SECUNIA
FreeBSD-SA-08:01http://security.FreeBSD.org/advisories/FreeBSD-SA-08:01.pty.ascFREEBSDPatch
27284http://www.securityfocus.com/bid/27284BID
1019191http://www.securitytracker.com/id?1019191SECTRACK
freebsd-openpty-information-disclosure(39665)https://exchange.xforce.ibmcloud.com/vulnerabilities/39665XF