CVE-2007-0063

Current Description

Integer underflow in the DHCP server in EMC VMware Workstation before 5.5.5 Build 56455 and 6.x before 6.0.1 Build 55017, Player before 1.0.5 Build 56455 and Player 2 before 2.0.1 Build 55017, ACE before 1.0.3 Build 54075 and ACE 2 before 2.0.1 Build 55017, and Server before 1.0.4 Build 56528 allows remote attackers to execute arbitrary code via a malformed DHCP packet that triggers a stack-based buffer overflow.

Basic Data

PublishedSeptember 21, 2007
Last ModifiedJuly 16, 2019
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-191
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:C/I:C/A:C
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactCOMPLETE
CVSS 2 - Availability ImpactCOMPLETE
CVSS 2 - Base Score10.0
SeverityHIGH
Exploitability Score10.0
Impact Score10.0
Obtain All Privilegetrue
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationVmwareAce********1.01.0.3
    2.3ApplicationVmwareAce********2.02.0.1
    2.3ApplicationVmwarePlayer********1.01.0.5
    2.3ApplicationVmwarePlayer********2.02.0.1
    2.3ApplicationVmwareServer********1.01.0.4
    2.3ApplicationVmwareWorkstation********5.55.5.5
    2.3ApplicationVmwareWorkstation********6.06.0.1
    2.3OSVmwareEsx2.0.2*******
    2.3OSVmwareEsx2.1.3*******
    2.3OSVmwareEsx2.5.3*******
    2.3OSVmwareEsx2.5.4*******
    2.3OSVmwareEsx3.0.0*******
    2.3OSVmwareEsx3.0.1*******
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3OSCanonicalUbuntu Linux6.06***lts***
    2.3OSCanonicalUbuntu Linux6.10*******
    2.3OSCanonicalUbuntu Linux7.04*******

Vulnerable Software List

VendorProductVersions
Canonical Ubuntu Linux 6.06, 6.10, 7.04
Vmware Workstation *
Vmware Esx 2.0.2, 2.1.3, 2.5.3, 2.5.4, 3.0.0, 3.0.1
Vmware Server *
Vmware Ace *
Vmware Player *

References

NameSourceURLTags
20070920 VMSA-2007-0006 Critical security updates for all supported versions of VMware ESX Server, VMware Server, VMware Workstation, VMware ACE, and VMware Playerhttp://lists.grok.org.uk/pipermail/full-disclosure/2007-September/065902.htmlFULLDISCThird Party Advisory
26890http://secunia.com/advisories/26890SECUNIAThird Party Advisory
27694http://secunia.com/advisories/27694SECUNIAThird Party Advisory
27706http://secunia.com/advisories/27706SECUNIAThird Party Advisory
GLSA-200711-23http://security.gentoo.org/glsa/glsa-200711-23.xmlGENTOOThird Party Advisory
20070919 VMWare DHCP Server Remote Code Execution Vulnerabilitieshttp://www.iss.net/threats/275.htmlISSPatch Third Party Advisory
25729http://www.securityfocus.com/bid/25729BIDPatch Third Party Advisory VDB Entry
1018717http://www.securitytracker.com/id?1018717SECTRACKThird Party Advisory VDB Entry
USN-543-1http://www.ubuntu.com/usn/usn-543-1UBUNTUThird Party Advisory
http://www.vmware.com/support/ace/doc/releasenotes_ace.htmlhttp://www.vmware.com/support/ace/doc/releasenotes_ace.htmlCONFIRMPatch Vendor Advisory
http://www.vmware.com/support/ace2/doc/releasenotes_ace2.htmlhttp://www.vmware.com/support/ace2/doc/releasenotes_ace2.htmlCONFIRMPatch Vendor Advisory
http://www.vmware.com/support/player/doc/releasenotes_player.htmlhttp://www.vmware.com/support/player/doc/releasenotes_player.htmlCONFIRMPatch Vendor Advisory
http://www.vmware.com/support/player2/doc/releasenotes_player2.htmlhttp://www.vmware.com/support/player2/doc/releasenotes_player2.htmlCONFIRMPatch Vendor Advisory
http://www.vmware.com/support/server/doc/releasenotes_server.htmlhttp://www.vmware.com/support/server/doc/releasenotes_server.htmlCONFIRMPatch Vendor Advisory
http://www.vmware.com/support/ws55/doc/releasenotes_ws55.htmlhttp://www.vmware.com/support/ws55/doc/releasenotes_ws55.htmlCONFIRMPatch Vendor Advisory
http://www.vmware.com/support/ws6/doc/releasenotes_ws6.htmlhttp://www.vmware.com/support/ws6/doc/releasenotes_ws6.htmlCONFIRMPatch Vendor Advisory
ADV-2007-3229http://www.vupen.com/english/advisories/2007/3229VUPENThird Party Advisory
dhcp-param-underflow(33103)https://exchange.xforce.ibmcloud.com/vulnerabilities/33103XFThird Party Advisory VDB Entry