CVE-2006-7225

Current Description

Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to cause a denial of service (error or crash) via a regular expression that involves a "malformed POSIX character class", as demonstrated via an invalid character after a [[ sequence.

Basic Data

PublishedDecember 03, 2007
Last ModifiedOctober 11, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeCWE-20
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:M/Au:N/C:N/I:N/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityMEDIUM
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactNONE
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score4.3
SeverityMEDIUM
Exploitability Score8.6
Impact Score2.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationPerlPcre0.91*******
    2.3ApplicationPerlPcre0.92*******
    2.3ApplicationPerlPcre0.93*******
    2.3ApplicationPerlPcre0.94*******
    2.3ApplicationPerlPcre0.95*******
    2.3ApplicationPerlPcre0.96*******
    2.3ApplicationPerlPcre0.97*******
    2.3ApplicationPerlPcre0.98*******
    2.3ApplicationPerlPcre0.99*******
    2.3ApplicationPerlPcre1.00*******
    2.3ApplicationPerlPcre1.01*******
    2.3ApplicationPerlPcre1.02*******
    2.3ApplicationPerlPcre1.03*******
    2.3ApplicationPerlPcre1.04*******
    2.3ApplicationPerlPcre1.05*******
    2.3ApplicationPerlPcre1.06*******
    2.3ApplicationPerlPcre1.07*******
    2.3ApplicationPerlPcre1.08*******
    2.3ApplicationPerlPcre1.09*******
    2.3ApplicationPerlPcre2.0*******
    2.3ApplicationPerlPcre2.01*******
    2.3ApplicationPerlPcre2.02*******
    2.3ApplicationPerlPcre2.03*******
    2.3ApplicationPerlPcre2.04*******
    2.3ApplicationPerlPcre2.05*******
    2.3ApplicationPerlPcre2.06*******
    2.3ApplicationPerlPcre2.07*******
    2.3ApplicationPerlPcre2.08*******
    2.3ApplicationPerlPcre3.0*******
    2.3ApplicationPerlPcre3.1*******
    2.3ApplicationPerlPcre3.2*******
    2.3ApplicationPerlPcre3.3*******
    2.3ApplicationPerlPcre3.4*******
    2.3ApplicationPerlPcre3.5*******
    2.3ApplicationPerlPcre3.6*******
    2.3ApplicationPerlPcre3.7*******
    2.3ApplicationPerlPcre3.8*******
    2.3ApplicationPerlPcre3.9*******
    2.3ApplicationPerlPcre4.0*******
    2.3ApplicationPerlPcre4.1*******
    2.3ApplicationPerlPcre4.2*******
    2.3ApplicationPerlPcre4.3*******
    2.3ApplicationPerlPcre4.4*******
    2.3ApplicationPerlPcre4.5*******
    2.3ApplicationPerlPcre5.0*******
    2.3ApplicationPerlPcre6.0*******
    2.3ApplicationPerlPcre6.1*******
    2.3ApplicationPerlPcre6.2*******
    2.3ApplicationPerlPcre6.3*******
    2.3ApplicationPerlPcre6.4*******
    2.3ApplicationPerlPcre6.5*******
    2.3ApplicationPerlPcre6.6*******

Vulnerable Software List

VendorProductVersions
Perl Pcre 0.91, 0.92, 0.93, 0.94, 0.95, 0.96, 0.97, 0.98, 0.99, 1.00, 1.01, 1.02, 1.03, 1.04, 1.05, 1.06, 1.07, 1.08, 1.09, 2.0, 2.01, 2.02, 2.03, 2.04, 2.05, 2.06, 2.07, 2.08, 3.0, 3.1, 3.2, 3.3, 3.4, 3.5, 3.6, 3.7, 3.8, 3.9, 4.0, 4.1, 4.2, 4.3, 4.4, 4.5, 5.0, 6.0, 6.1, 6.2, 6.3, 6.4, 6.5, 6.6

References

NameSourceURLTags
SUSE-SA:2008:004http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00006.htmlSUSE
28041http://secunia.com/advisories/28041SECUNIA
28658http://secunia.com/advisories/28658SECUNIA
http://support.avaya.com/elmodocs2/security/ASA-2007-505.htmhttp://support.avaya.com/elmodocs2/security/ASA-2007-505.htmCONFIRM
MDVSA-2008:030http://www.mandriva.com/security/advisories?name=MDVSA-2008:030MANDRIVA
http://www.pcre.org/changelog.txthttp://www.pcre.org/changelog.txtCONFIRM
RHSA-2007:1059http://www.redhat.com/support/errata/RHSA-2007-1059.htmlREDHATPATCH
RHSA-2007:1068http://www.redhat.com/support/errata/RHSA-2007-1068.htmlREDHATPATCH
26725http://www.securityfocus.com/bid/26725BID
https://bugzilla.redhat.com/show_bug.cgi?id=384761https://bugzilla.redhat.com/show_bug.cgi?id=384761MISC
oval:org.mitre.oval:def:10985https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10985OVAL