CVE-2006-6487

Current Description

Cross-site scripting (XSS) vulnerability in index.php in DT Guestbook (dt_guestbook) 1.0f, when register_globals is enabled, allows remote attackers to inject arbitrary web script or HTML via the error[] parameter.

Evaluator Description

Successful exploitation requires that "register_globals" is enabled.

Basic Data

PublishedJanuary 16, 2007
Last ModifiedOctober 17, 2018
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:H/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityHIGH
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score5.1
SeverityMEDIUM
Exploitability Score4.9
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegetrue

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationDt GuestbookDt Guestbook1.0f*******

Vulnerable Software List

VendorProductVersions
Dt Guestbook Dt Guestbook 1.0f

References

NameSourceURLTags
23778http://secunia.com/advisories/23778SECUNIAExploit Vendor Advisory
http://www.netvigilance.com/advisory0010http://www.netvigilance.com/advisory0010MISCExploit Vendor Advisory
30787http://www.osvdb.org/30787OSVDBExploit
20070116 dt_guestbook version 1.0f XSS vulnerabilityhttp://www.securityfocus.com/archive/1/457059/100/0/threadedBUGTRAQ
22078http://www.securityfocus.com/bid/22078BID
ADV-2007-0205http://www.vupen.com/english/advisories/2007/0205VUPEN
dtguestbook-index-xss(31518)https://exchange.xforce.ibmcloud.com/vulnerabilities/31518XF