CVE-2006-5262

Current Description

CRLF injection vulnerability in lib/session.php in Hastymail 1.5 and earlier before 20061008 allows remote authenticated users to send arbitrary IMAP commands via a CRLF sequence in a mailbox name. NOTE: the attack crosses privilege boundaries if the IMAP server configuration prevents a user from establishing a direct IMAP session.

Referenced by CVEs:CVE-2006-5313

Basic Data

PublishedOctober 12, 2006
Last ModifiedOctober 17, 2018
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:S/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationSINGLE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score6.5
SeverityMEDIUM
Exploitability Score8.0
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegetrue

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationHastymailHastymail1.0.1*******
    2.3ApplicationHastymailHastymail1.0.2*******
    2.3ApplicationHastymailHastymail1.1*******
    2.3ApplicationHastymailHastymail1.2*******
    2.3ApplicationHastymailHastymail********1.5

Vulnerable Software List

VendorProductVersions
Hastymail Hastymail *, 1.0.1, 1.0.2, 1.1, 1.2

References

NameSourceURLTags
http://hastymail.sourceforge.net/security.phphttp://hastymail.sourceforge.net/security.phpCONFIRMPatch
22308http://secunia.com/advisories/22308SECUNIAPatch Vendor Advisory
20061202 [ISecAuditors Security Advisories] IMAP/SMTP Injection in Hastymailhttp://www.securityfocus.com/archive/1/453417/100/0/threadedBUGTRAQ
20424http://www.securityfocus.com/bid/20424BIDPatch
ADV-2006-3956http://www.vupen.com/english/advisories/2006/3956VUPEN
hastymail-imap-command-execution(29407)https://exchange.xforce.ibmcloud.com/vulnerabilities/29407XF