CVE-2006-4169

Current Description

Multiple directory traversal vulnerabilities in the G/PGP (GPG) Plugin 2.0, and 2.1dev before 20070614, for Squirrelmail allow remote authenticated users to include and execute arbitrary local files via a .. (dot dot) in the help parameter to (1) gpg_help.php or (2) gpg_help_base.php.

Evaluator Description

The vendor has addressed this issue in the following product update: http://www.squirrelmail.org/plugin_download.php?id=153&rev=1303

Referenced by CVEs:CVE-2007-3635

Basic Data

PublishedJuly 15, 2007
Last ModifiedJuly 20, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:S/C:P/I:P/A:N
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationSINGLE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactNONE
CVSS 2 - Base Score5.5
SeverityMEDIUM
Exploitability Score8.0
Impact Score4.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationSquirrelmailGpg Plugin2.0*******
    2.3ApplicationSquirrelmailGpg Plugin2.1_dev*******

Vulnerable Software List

VendorProductVersions
Squirrelmail Gpg Plugin 2.0, 2.1_dev

References

NameSourceURLTags
20070711 SquirrelMail G/PGP Plugin gpg_help.php Local File Inclusion Vulnerabilityhttp://labs.idefense.com/intelligence/vulnerabilities/display.php?id=555IDEFENSE
37932http://osvdb.org/37932OSVDB
37933http://osvdb.org/37933OSVDB
26035http://secunia.com/advisories/26035SECUNIAVendor Advisory
26424http://secunia.com/advisories/26424SECUNIA
GLSA-200708-08http://security.gentoo.org/glsa/glsa-200708-08.xmlGENTOO
24874http://www.securityfocus.com/bid/24874BID
ADV-2007-2513http://www.vupen.com/english/advisories/2007/2513VUPEN
squirrelmail-gpgp-help-file-include(35362)https://exchange.xforce.ibmcloud.com/vulnerabilities/35362XF