CVE-2005-0096

Current Description

Memory leak in the NTLM fakeauth_auth helper for Squid 2.5.STABLE7 and earlier allows remote attackers to cause a denial of service (memory consumption).

Basic Data

PublishedJanuary 25, 2005
Last ModifiedOctober 11, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:N/I:N/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactNONE
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score5.0
SeverityMEDIUM
Exploitability Score10.0
Impact Score2.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationSquidSquid2.0_patch2*******
    2.3ApplicationSquidSquid2.1_patch2*******
    2.3ApplicationSquidSquid2.3_.stable4*******
    2.3ApplicationSquidSquid2.3_.stable5*******
    2.3ApplicationSquidSquid2.3_stable5*******
    2.3ApplicationSquidSquid2.4*******
    2.3ApplicationSquidSquid2.4_.stable2*******
    2.3ApplicationSquidSquid2.4_.stable6*******
    2.3ApplicationSquidSquid2.4_.stable7*******
    2.3ApplicationSquidSquid2.4_stable7*******
    2.3ApplicationSquidSquid2.5.6*******
    2.3ApplicationSquidSquid2.5.stable1*******
    2.3ApplicationSquidSquid2.5.stable2*******
    2.3ApplicationSquidSquid2.5.stable3*******
    2.3ApplicationSquidSquid2.5.stable4*******
    2.3ApplicationSquidSquid2.5.stable5*******
    2.3ApplicationSquidSquid2.5.stable6*******
    2.3ApplicationSquidSquid2.5.stable7*******
    2.3ApplicationSquidSquid2.5_.stable1*******
    2.3ApplicationSquidSquid2.5_.stable3*******
    2.3ApplicationSquidSquid2.5_.stable4*******
    2.3ApplicationSquidSquid2.5_.stable5*******
    2.3ApplicationSquidSquid2.5_.stable6*******
    2.3ApplicationSquidSquid2.5_stable3*******
    2.3ApplicationSquidSquid2.5_stable4*******
    2.3ApplicationSquidSquid2.5_stable9*******
    2.3ApplicationSquidSquid2.6.stable1*******

Vulnerable Software List

VendorProductVersions
Squid Squid 2.0_patch2, 2.1_patch2, 2.3_.stable4, 2.3_.stable5, 2.3_stable5, 2.4, 2.4_.stable2, 2.4_.stable6, 2.4_.stable7, 2.4_stable7, 2.5.6, 2.5.stable1, 2.5.stable2, 2.5.stable3, 2.5.stable4, 2.5.stable5, 2.5.stable6, 2.5.stable7, 2.5_.stable1, 2.5_.stable3, 2.5_.stable4, 2.5_.stable5, 2.5_.stable6, 2.5_stable3, 2.5_stable4, 2.5_stable9, 2.6.stable1

References

NameSourceURLTags
CLA-2005:923http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000923CONECTIVAPatch Vendor Advisory
FLSA-2006:152809http://fedoranews.org/updates/FEDORA--.shtmlFEDORA
GLSA-200501-25http://security.gentoo.org/glsa/glsa-200501-25.xmlGENTOOPatch Vendor Advisory
1012818http://securitytracker.com/id?1012818SECTRACK
SUSE-SA:2005:006http://www.novell.com/linux/security/advisories/2005_06_squid.htmlSUSEVendor Advisory
RHSA-2005:060http://www.redhat.com/support/errata/RHSA-2005-060.htmlREDHATPatch Vendor Advisory
RHSA-2005:061http://www.redhat.com/support/errata/RHSA-2005-061.htmlREDHATPatch Vendor Advisory
12324http://www.securityfocus.com/bid/12324BID
http://www.squid-cache.org/Versions/v2/2.5/bugs/#squid-2.5.STABLE7-fakeauth_authhttp://www.squid-cache.org/Versions/v2/2.5/bugs/#squid-2.5.STABLE7-fakeauth_authCONFIRMPatch Vendor Advisory
2005-0003http://www.trustix.org/errata/2005/0003/TRUSTIXVendor Advisory
oval:org.mitre.oval:def:10233https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10233OVAL