CVE-2005-0021

Current Description

Multiple buffer overflows in Exim before 4.43 may allow attackers to execute arbitrary code via (1) an IPv6 address with more than 8 components, as demonstrated using the -be command line option, which triggers an overflow in the host_aton function, or (2) the -bh command line option or dnsdb PTR lookup, which triggers an overflow in the dns_build_reverse function.

Basic Data

PublishedMay 02, 2005
Last ModifiedOctober 11, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:L/AC:L/Au:N/C:C/I:C/A:C
CVSS 2 - Access VectorLOCAL
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactCOMPLETE
CVSS 2 - Availability ImpactCOMPLETE
CVSS 2 - Base Score7.2
SeverityHIGH
Exploitability Score3.9
Impact Score10.0
Obtain All Privilegetrue
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationUniversity Of CambridgeExim********4.40
    2.3ApplicationUniversity Of CambridgeExim4.41*******
    2.3ApplicationUniversity Of CambridgeExim4.42*******

Vulnerable Software List

VendorProductVersions
University Of Cambridge Exim *, 4.41, 4.42

References

NameSourceURLTags
http://ftp6.us.freebsd.org/pub/mail/exim/ChangeLogs/ChangeLog-4.44http://ftp6.us.freebsd.org/pub/mail/exim/ChangeLogs/ChangeLog-4.44CONFIRM
GLSA-200501-23http://security.gentoo.org/glsa/glsa-200501-23.xmlGENTOOVendor Advisory
DSA-635http://www.debian.org/security/2005/dsa-635DEBIANVendor Advisory
DSA-637http://www.debian.org/security/2005/dsa-637DEBIANVendor Advisory
[exim] 20050104 2 smallish security issueshttp://www.exim.org/mail-archives/exim-users/Week-of-Mon-20050103/msg00028.htmlMLIST
20050107 Exim host_aton() Buffer Overflow Vulnerabilityhttp://www.idefense.com/application/poi/display?id=179&type=vulnerabilitiesIDEFENSEVendor Advisory
20050114 Exim dns_buld_reverse() Buffer Overflow Vulnerabilityhttp://www.idefense.com/application/poi/display?id=183&type=vulnerabilitiesIDEFENSEExploit Vendor Advisory
VU#132992http://www.kb.cert.org/vuls/id/132992CERT-VNPatch US Government Resource
RHSA-2005:025http://www.redhat.com/support/errata/RHSA-2005-025.htmlREDHATPatch
oval:org.mitre.oval:def:10347https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10347OVAL