CVE-2004-0947

Current Description

Buffer overflow in unarj before 2.63a-r2 allows remote attackers to execute arbitrary code via an arj archive that contains long filenames.

Basic Data

PublishedFebruary 09, 2005
Last ModifiedJuly 11, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:C/I:C/A:C
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactCOMPLETE
CVSS 2 - Availability ImpactCOMPLETE
CVSS 2 - Base Score10.0
SeverityHIGH
Exploitability Score10.0
Impact Score10.0
Obtain All Privilegetrue
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationArj Software Inc.Unarj2.62*******
    2.3ApplicationArj Software Inc.Unarj2.63_a*******
    2.3ApplicationArj Software Inc.Unarj2.64*******
    2.3ApplicationArj Software Inc.Unarj2.65*******
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3OSGentooLinux********
    2.3OSSuseSuse Linux9.0*******
    2.3OSSuseSuse Linux9.1*******
    2.3OSSuseSuse Linux9.2*******

Vulnerable Software List

VendorProductVersions
Arj Software Inc. Unarj 2.62, 2.63_a, 2.64, 2.65
Suse Suse Linux 9.0, 9.1, 9.2
Gentoo Linux *

References

NameSourceURLTags
FLSA:2272http://lwn.net/Articles/121827/FEDORA
DSA-652http://www.debian.org/security/2005/dsa-652DEBIAN
GLSA-200411-29http://www.gentoo.org/security/en/glsa/glsa-200411-29.xmlGENTOOPatch Vendor Advisory
RHSA-2005:007http://www.redhat.com/support/errata/RHSA-2005-007.htmlREDHAT
11665http://www.securityfocus.com/bid/11665BIDPatch Vendor Advisory
unarj-longfilename-bo(18044)https://exchange.xforce.ibmcloud.com/vulnerabilities/18044XF