CVE-2004-0559

Current Description

The maketemp.pl script in Usermin 1.070 and 1.080 allows local users to overwrite arbitrary files at install time via a symlink attack on the /tmp/.usermin directory.

Basic Data

PublishedOctober 20, 2004
Last ModifiedJuly 11, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:L/AC:L/Au:N/C:N/I:P/A:N
CVSS 2 - Access VectorLOCAL
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactNONE
CVSS 2 - Availability ImpactNONE
CVSS 2 - Base Score2.1
SeverityLOW
Exploitability Score3.9
Impact Score2.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationUserminUsermin1.000*******
    2.3ApplicationUserminUsermin1.010*******
    2.3ApplicationUserminUsermin1.020*******
    2.3ApplicationUserminUsermin1.030*******
    2.3ApplicationUserminUsermin1.040*******
    2.3ApplicationUserminUsermin1.051*******
    2.3ApplicationUserminUsermin1.060*******
    2.3ApplicationUserminUsermin1.070*******
    2.3ApplicationUserminUsermin1.080*******
    2.3ApplicationWebminWebmin1.0.00*******
    2.3ApplicationWebminWebmin1.0.20*******
    2.3ApplicationWebminWebmin1.0.50*******
    2.3ApplicationWebminWebmin1.0.60*******
    2.3ApplicationWebminWebmin1.0.70*******
    2.3ApplicationWebminWebmin1.0.80*******
    2.3ApplicationWebminWebmin1.0.90*******
    2.3ApplicationWebminWebmin1.1.00*******
    2.3ApplicationWebminWebmin1.1.10*******
    2.3ApplicationWebminWebmin1.1.21*******
    2.3ApplicationWebminWebmin1.1.30*******
    2.3ApplicationWebminWebmin1.1.40*******
    2.3ApplicationWebminWebmin1.1.50*******
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3OSMandrakesoftMandrake Linux9.2*******
    2.3OSMandrakesoftMandrake Linux9.2*amd64*****
    2.3OSMandrakesoftMandrake Linux10.0*******
    2.3OSMandrakesoftMandrake Linux10.0*amd64*****
    2.3OSMandrakesoftMandrake Linux Corporate Server2.1*******
    2.3OSMandrakesoftMandrake Linux Corporate Server2.1*x86_64*****

Vulnerable Software List

VendorProductVersions
Mandrakesoft Mandrake Linux 10.0, 9.2
Mandrakesoft Mandrake Linux Corporate Server 2.1
Usermin Usermin 1.000, 1.010, 1.020, 1.030, 1.040, 1.051, 1.060, 1.070, 1.080
Webmin Webmin 1.0.00, 1.0.20, 1.0.50, 1.0.60, 1.0.70, 1.0.80, 1.0.90, 1.1.00, 1.1.10, 1.1.21, 1.1.30, 1.1.40, 1.1.50

References

NameSourceURLTags
12488http://secunia.com/advisories/12488/SECUNIAPATCH Vendor Advisory
GLSA-200409-15http://www.gentoo.org/security/en/glsa/glsa-200409-15.xmlGENTOOPATCH Vendor Advisory
11153http://www.securityfocus.com/bid/11153BIDPATCH Vendor Advisory
http://www.webmin.com/uchanges-1.089.htmlhttp://www.webmin.com/uchanges-1.089.htmlCONFIRM
usermin-installation-unspecified(17299)https://exchange.xforce.ibmcloud.com/vulnerabilities/17299XF