CVE-2004-0495

Current Description

Multiple unknown vulnerabilities in Linux kernel 2.4 and 2.6 allow local users to gain privileges or access kernel memory, as found by the Sparse source code checking tool.

Referenced by CVEs:CVE-2004-0496

Basic Data

PublishedAugust 06, 2004
Last ModifiedOctober 11, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:L/AC:L/Au:N/C:C/I:C/A:C
CVSS 2 - Access VectorLOCAL
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactCOMPLETE
CVSS 2 - Availability ImpactCOMPLETE
CVSS 2 - Base Score7.2
SeverityHIGH
Exploitability Score3.9
Impact Score10.0
Obtain All Privilegetrue
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3HardwareAvayaConverged Communications Server2.0*******
    2.3OSAvayaModular Messaging Message Storage Servers3400*******
    2.3OSGentooLinux1.4*******
    2.3OSLinuxLinux Kernel2.4.18*******
    2.3OSLinuxLinux Kernel2.4.19*******
    2.3OSLinuxLinux Kernel2.4.21*******
    2.3OSLinuxLinux Kernel2.4.22*******
    2.3OSLinuxLinux Kernel2.4.23*******
    2.3OSLinuxLinux Kernel2.4.24*******
    2.3OSLinuxLinux Kernel2.4.25*******
    2.3OSLinuxLinux Kernel2.4.26*******
    2.3OSLinuxLinux Kernel2.6.0*******
    2.3OSLinuxLinux Kernel2.6.1*******
    2.3OSLinuxLinux Kernel2.6.1rc1******
    2.3OSLinuxLinux Kernel2.6.1rc2******
    2.3OSLinuxLinux Kernel2.6.2*******
    2.3OSLinuxLinux Kernel2.6.3*******
    2.3OSLinuxLinux Kernel2.6.4*******
    2.3OSLinuxLinux Kernel2.6.5*******
    2.3OSLinuxLinux Kernel2.6.6*******
    2.3OSLinuxLinux Kernel2.6.6rc1******
    2.3OSLinuxLinux Kernel2.6.7*******
    2.3OSLinuxLinux Kernel2.6.7rc1******
    2.3OSRedhatEnterprise Linux2.1*advanced_server*****
    2.3OSRedhatEnterprise Linux2.1*enterprise_server*****
    2.3OSRedhatEnterprise Linux2.1*workstation*****
    2.3OSRedhatEnterprise Linux3.0*advanced_servers*****
    2.3OSRedhatEnterprise Linux3.0*enterprise_server*****
    2.3OSRedhatEnterprise Linux3.0*workstation*****
    2.3OSSuseSuse Linux7*enterprise_server*****
    2.3OSSuseSuse Linux8*enterprise_server*****
    2.3OSSuseSuse Linux8.0*******
    2.3OSSuseSuse Linux8.0*i386*****
    2.3OSSuseSuse Linux8.1*******
    2.3OSSuseSuse Linux8.2*******
    2.3OSSuseSuse Linux9.0*******
    2.3OSSuseSuse Linux9.0*x86_64*****
    2.3OSSuseSuse Linux9.1*******
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationAvayaIntuity Audix**lx*****
    2.3ApplicationSuseSuse Email Server3.1*******
    2.3ApplicationSuseSuse Email Serveriii*******
    2.3ApplicationSuseSuse Linux Admin-cd For Firewall********
    2.3ApplicationSuseSuse Linux Connectivity Server********
    2.3ApplicationSuseSuse Linux Database Server********
    2.3ApplicationSuseSuse Linux Firewall Cd********
    2.3ApplicationSuseSuse Linux Office Server********
    2.3ApplicationSuseSuse Office Server********
    2.3HardwareAvayaS8300r2.0.0*******
    2.3HardwareAvayaS8300r2.0.1*******
    2.3HardwareAvayaS8500r2.0.0*******
    2.3HardwareAvayaS8500r2.0.1*******
    2.3HardwareAvayaS8700r2.0.0*******
    2.3HardwareAvayaS8700r2.0.1*******
    2.3OSConectivaLinux8.0*******
    2.3OSConectivaLinux9.0*******

Vulnerable Software List

VendorProductVersions
Avaya S8300 r2.0.0, r2.0.1
Avaya Intuity Audix *
Avaya S8500 r2.0.0, r2.0.1
Avaya S8700 r2.0.0, r2.0.1
Avaya Modular Messaging Message Storage Server s3400
Avaya Converged Communications Server 2.0
Redhat Enterprise Linux 2.1, 3.0
Conectiva Linux 8.0, 9.0
Linux Linux Kernel 2.4.18, 2.4.19, 2.4.21, 2.4.22, 2.4.23, 2.4.24, 2.4.25, 2.4.26, 2.6.0, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.6.5, 2.6.6, 2.6.7
Suse Suse Linux Office Server *
Suse Suse Office Server *
Suse Suse Linux 7, 8, 8.0, 8.1, 8.2, 9.0, 9.1
Suse Suse Email Server 3.1, iii
Suse Suse Linux Admin-cd For Firewall *
Suse Suse Linux Connectivity Server *
Suse Suse Linux Database Server *
Suse Suse Linux Firewall Cd *
Gentoo Linux 1.4

References

NameSourceURLTags
CLA-2004:845http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000845CONECTIVA
CLA-2004:846http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000846CONECTIVA
FEDORA-2004-186http://lwn.net/Articles/91155/FEDORA
GLSA-200407-02http://security.gentoo.org/glsa/glsa-200407-02.xmlGENTOOVendor Advisory
MDKSA-2004:066http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:066MANDRAKE
SUSE-SA:2004:020http://www.novell.com/linux/security/advisories/2004_20_kernel.htmlSUSE
RHSA-2004:255http://www.redhat.com/support/errata/RHSA-2004-255.htmlREDHATPATCH Vendor Advisory
RHSA-2004:260http://www.redhat.com/support/errata/RHSA-2004-260.htmlREDHAT
10566http://www.securityfocus.com/bid/10566BIDPATCH Vendor Advisory
linux-drivers-gain-privileges(16449)https://exchange.xforce.ibmcloud.com/vulnerabilities/16449XF
oval:org.mitre.oval:def:10155https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10155OVAL
oval:org.mitre.oval:def:2961https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A2961OVAL