CVE-2004-0490

Current Description

cPanel, when compiling Apache 1.3.29 and PHP with the mod_phpsuexec option, does not set the --enable-discard-path option, which causes php to use the SCRIPT_FILENAME variable to find and execute a script instead of the PATH_TRANSLATED variable, which allows local users to execute arbitrary PHP code as other users via a URL that references the attacker's script after the user's script, which executes the attacker's script with the user's privileges, a different vulnerability than CVE-2004-0529.

Referenced by CVEs:CVE-2004-0529

Basic Data

PublishedAugust 18, 2004
Last ModifiedJuly 11, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:L/AC:L/Au:N/C:C/I:C/A:C
CVSS 2 - Access VectorLOCAL
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactCOMPLETE
CVSS 2 - Availability ImpactCOMPLETE
CVSS 2 - Base Score7.2
SeverityHIGH
Exploitability Score3.9
Impact Score10.0
Obtain All Privilegetrue
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationCpanelCpanel5.0*******
    2.3ApplicationCpanelCpanel5.3*******
    2.3ApplicationCpanelCpanel6.0*******
    2.3ApplicationCpanelCpanel6.2*******
    2.3ApplicationCpanelCpanel6.4*******
    2.3ApplicationCpanelCpanel6.4.1*******
    2.3ApplicationCpanelCpanel6.4.2*******
    2.3ApplicationCpanelCpanel6.4.2_stable_48*******
    2.3ApplicationCpanelCpanel7.0*******
    2.3ApplicationCpanelCpanel8.0*******
    2.3ApplicationCpanelCpanel9.0*******
    2.3ApplicationCpanelCpanel9.1*******
    2.3ApplicationCpanelCpanel9.1.0_r85*******

Vulnerable Software List

VendorProductVersions
Cpanel Cpanel 5.0, 5.3, 6.0, 6.2, 6.4, 6.4.1, 6.4.2, 6.4.2_stable_48, 7.0, 8.0, 9.0, 9.1, 9.1.0_r85

References

NameSourceURLTags
http://bugzilla.cpanel.net/show_bug.cgi?id=283http://bugzilla.cpanel.net/show_bug.cgi?id=283MISC
http://bugzilla.cpanel.net/show_bug.cgi?id=664http://bugzilla.cpanel.net/show_bug.cgi?id=664CONFIRM
http://www.a-squad.com/audit/explain10.htmlhttp://www.a-squad.com/audit/explain10.htmlMISC
http://www.securiteam.com/tools/5TP0N15CUA.htmlhttp://www.securiteam.com/tools/5TP0N15CUA.htmlMISCVendor Advisory
20040524 cPanel mod_phpsuexec Vulnerabilityhttp://www.securityfocus.com/archive/1/364112BUGTRAQ
10407http://www.securityfocus.com/bid/10407BIDExploit Vendor Advisory
cpanel-modphpsuexec-execute-commands(16239)https://exchange.xforce.ibmcloud.com/vulnerabilities/16239XF