CVE-2004-0224

Current Description

Multiple buffer overflows in (1) iso2022jp.c or (2) shiftjis.c for Courier-IMAP before 3.0.0, Courier before 0.45, and SqWebMail before 4.0.0 may allow remote attackers to execute arbitrary code "when Unicode character is out of BMP range."

Basic Data

PublishedApril 15, 2004
Last ModifiedJuly 11, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score7.5
SeverityHIGH
Exploitability Score10.0
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegetrue

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationDouble Precision IncorporatedCourier Mta0.43*******
    2.3ApplicationDouble Precision IncorporatedCourier Mta0.43.1*******
    2.3ApplicationDouble Precision IncorporatedCourier Mta0.43.2*******
    2.3ApplicationDouble Precision IncorporatedCourier Mta0.44*******
    2.3ApplicationDouble Precision IncorporatedCourier Mta0.44.2*******
    2.3ApplicationDouble Precision IncorporatedSqwebmail3.5.2*******
    2.3ApplicationDouble Precision IncorporatedSqwebmail3.5.3*******
    2.3ApplicationDouble Precision IncorporatedSqwebmail3.6.1*******
    2.3ApplicationDouble Precision IncorporatedSqwebmail3.6.2*******
    2.3ApplicationDouble Precision IncorporatedSqwebmail3.6_.0*******
    2.3ApplicationInter7Courier-imap1.6*******
    2.3ApplicationInter7Courier-imap1.7*******
    2.3ApplicationInter7Courier-imap2.0.0*******
    2.3ApplicationInter7Courier-imap2.1*******
    2.3ApplicationInter7Courier-imap2.1.1*******
    2.3ApplicationInter7Courier-imap2.1.2*******
    2.3ApplicationInter7Courier-imap2.2.0*******
    2.3ApplicationInter7Courier-imap2.2.1*******
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3OSGentooLinux1.4*******
    2.3OSGentooLinux1.4rc1******
    2.3OSGentooLinux1.4rc2******
    2.3OSGentooLinux1.4rc3******

Vulnerable Software List

VendorProductVersions
Inter7 Courier-imap 1.6, 1.7, 2.0.0, 2.1, 2.1.1, 2.1.2, 2.2.0, 2.2.1
Double Precision Incorporated Sqwebmail 3.5.2, 3.5.3, 3.6.1, 3.6.2, 3.6_.0
Double Precision Incorporated Courier Mta 0.43, 0.43.1, 0.43.2, 0.44, 0.44.2
Gentoo Linux 1.4

References

NameSourceURLTags
11087http://secunia.com/advisories/11087/SECUNIAPATCH Vendor Advisory
http://sourceforge.net/project/shownotes.php?release_id=5767http://sourceforge.net/project/shownotes.php?release_id=5767CONFIRMVendor Advisory
9845http://www.securityfocus.com/bid/9845BIDPATCH Vendor Advisory
courier-codeset-converter-bo(15434)https://exchange.xforce.ibmcloud.com/vulnerabilities/15434XF