CVE-2004-0194

Current Description

Stack-based buffer overflow in the OutputDebugString function for Adobe Acrobat Reader 5.1 allows remote attackers to execute arbitrary code via a PDF document with XML Forms Data Format (XFDF) data.

Basic Data

PublishedMarch 29, 2004
Last ModifiedOctober 10, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score7.5
SeverityHIGH
Exploitability Score10.0
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegetrue

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationAdobeAcrobat Reader5.1*******

Vulnerable Software List

VendorProductVersions
Adobe Acrobat Reader 5.1

References

NameSourceURLTags
20040303 Adobe Acrobat Reader XML Forms Data Format Buffer Overflowhttp://lists.grok.org.uk/pipermail/full-disclosure/2004-March/018227.htmlFULLDISC
20040303 Abobe Reader 5.1 XFDF Buffer Overflow Vulnerabilityhttp://marc.info/?l=bugtraq&m=107842545022724&w=2BUGTRAQ
http://www.nextgenss.com/advisories/adobexfdf.txthttp://www.nextgenss.com/advisories/adobexfdf.txtMISCPATCH Vendor Advisory
4135http://www.osvdb.org/4135OSVDB
9802http://www.securityfocus.com/bid/9802BIDPATCH Vendor Advisory
acrobatreader-xfdf-bo(15384)https://exchange.xforce.ibmcloud.com/vulnerabilities/15384XF