CVE-2004-0093

Current Description

XFree86 4.1.0 allows remote attackers to cause a denial of service and possibly execute arbitrary code via an out-of-bounds array index when using the GLX extension and Direct Rendering Infrastructure (DRI).

Basic Data

PublishedMarch 15, 2004
Last ModifiedOctober 10, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score7.5
SeverityHIGH
Exploitability Score10.0
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegetrue

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationXfree86 ProjectX11r64.1.0*******
    2.3ApplicationXfree86 ProjectX11r64.1.11*******
    2.3ApplicationXfree86 ProjectX11r64.1.12*******
    2.3ApplicationXfree86 ProjectX11r64.2.0*******
    2.3ApplicationXfree86 ProjectX11r64.2.1*******
    2.3ApplicationXfree86 ProjectX11r64.2.1*errata*****
    2.3ApplicationXfree86 ProjectX11r64.3.0*******

Vulnerable Software List

VendorProductVersions
Xfree86 Project X11r6 4.1.0, 4.1.11, 4.1.12, 4.2.0, 4.2.1, 4.3.0

References

NameSourceURLTags
20040406-01-Uftp://patches.sgi.com/support/free/security/advisories/20040406-01-USGI
CLSA-2004:824http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000824CONECTIVA
DSA-443http://www.debian.org/security/2004/dsa-443DEBIANPATCH Vendor Advisory
RHSA-2004:152http://www.redhat.com/support/errata/RHSA-2004-152.htmlREDHAT
9701http://www.securityfocus.com/bid/9701BIDVendor Advisory
xfree86-glx-array-dos(15272)https://exchange.xforce.ibmcloud.com/vulnerabilities/15272XF