CVE-2003-0204

Current Description

KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.

Basic Data

PublishedMay 05, 2003
Last ModifiedOctober 18, 2016
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score7.5
SeverityHIGH
Exploitability Score10.0
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegetrue
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3OSKdeKde2.0*******
    2.3OSKdeKde2.0.1*******
    2.3OSKdeKde2.1*******
    2.3OSKdeKde2.1.1*******
    2.3OSKdeKde2.1.2*******
    2.3OSKdeKde2.2*******
    2.3OSKdeKde2.2.1*******
    2.3OSKdeKde2.2.2*******
    2.3OSKdeKde3.0*******
    2.3OSKdeKde3.0.1*******
    2.3OSKdeKde3.0.2*******
    2.3OSKdeKde3.0.3*******
    2.3OSKdeKde3.0.3a*******
    2.3OSKdeKde3.0.4*******
    2.3OSKdeKde3.0.5*******
    2.3OSKdeKde3.0.5a*******
    2.3OSKdeKde3.1*******
    2.3OSKdeKde3.1.1*******

Vulnerable Software List

VendorProductVersions
Kde Kde 2.0, 2.0.1, 2.1, 2.1.1, 2.1.2, 2.2, 2.2.1, 2.2.2, 3.0, 3.0.1, 3.0.2, 3.0.3, 3.0.3a, 3.0.4, 3.0.5, 3.0.5a, 3.1, 3.1.1

References

NameSourceURLTags
http://bugs.kde.org/show_bug.cgi?id=53343http://bugs.kde.org/show_bug.cgi?id=53343CONFIRM
http://bugs.kde.org/show_bug.cgi?id=56808http://bugs.kde.org/show_bug.cgi?id=56808CONFIRM
CLA-2003:668http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000668CONECTIVA
CLA-2003:747http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000747CONECTIVA
20030410 GLSA: kde-3.x (200304-04)http://marc.info/?l=bugtraq&m=105001557020141&w=2BUGTRAQ
20030411 GLSA: kde-2.x (200304-05)http://marc.info/?l=bugtraq&m=105012994719099&w=2BUGTRAQ
20030412 [Sorcerer-spells] KDE-SORCERER2003-04-12http://marc.info/?l=bugtraq&m=105017403010459&w=2BUGTRAQ
20030414 GLSA: kde-2.x (200304-05.1)http://marc.info/?l=bugtraq&m=105034222521369&w=2BUGTRAQ
DSA-284http://www.debian.org/security/2003/dsa-284DEBIANPatch Vendor Advisory
DSA-293http://www.debian.org/security/2003/dsa-293DEBIAN
DSA-296http://www.debian.org/security/2003/dsa-296DEBIAN
http://www.kde.org/info/security/advisory-20030409-1.txthttp://www.kde.org/info/security/advisory-20030409-1.txtCONFIRMPatch Vendor Advisory
MDKSA-2003:049http://www.mandriva.com/security/advisories?name=MDKSA-2003:049MANDRAKE
RHSA-2003:002http://www.redhat.com/support/errata/RHSA-2003-002.htmlREDHAT