CVE-2001-1379

Current Description

The PostgreSQL authentication modules (1) mod_auth_pgsql 0.9.5, and (2) mod_auth_pgsql_sys 0.9.4, allow remote attackers to bypass authentication and execute arbitrary SQL via a SQL injection attack on the user name.

Basic Data

PublishedAugust 29, 2001
Last ModifiedJuly 11, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:N/AC:L/Au:N/C:P/I:P/A:P
CVSS 2 - Access VectorNETWORK
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactPARTIAL
CVSS 2 - Base Score7.5
SeverityHIGH
Exploitability Score10.0
Impact Score6.4
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegetrue

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationGuiseppe Tanzilli And Matthias EckermannMod Auth Pgsql0.9.5*******
    2.3ApplicationGuiseppe Tanzilli And Matthias EckermannMod Auth Pgsql0.9.6*******

Vulnerable Software List

VendorProductVersions
Guiseppe Tanzilli And Matthias Eckermann Mod Auth Pgsql 0.9.5, 0.9.6

References

NameSourceURLTags
FreeBSD-SA-02:03ftp://ftp.freebsd.org/pub/FreeBSD/CERT/advisories/FreeBSD-SA-02:03.mod_auth_pgsql.ascFREEBSD
20010829 [VulnWatch] RUS-CERT Advisory 2001-08:01http://archives.neohapsis.com/archives/vulnwatch/2001-q3/0040.htmlVULNWATCH
CLA-2001:427http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000427CONECTIVA
20010829 RUS-CERT Advisory 2001-08:01http://marc.info/?l=bugtraq&m=99911895901812&w=2BUGTRAQ
RHSA-2001:124http://rhn.redhat.com/errata/RHSA-2001-124.htmlREDHAT
apache-postgresql-authentication-module(7054)http://www.iss.net/security_center/static/7054.phpXFPatch Vendor Advisory
3251http://www.securityfocus.com/bid/3251BID
3253http://www.securityfocus.com/bid/3253BID
apache-postgresqlsys-authentication-module(7059)https://exchange.xforce.ibmcloud.com/vulnerabilities/7059XF