CVE-2001-0170

Current Description

glibc 2.1.9x and earlier does not properly clear the RESOLV_HOST_CONF, HOSTALIASES, or RES_OPTIONS environmental variables when executing setuid/setgid programs, which could allow local users to read arbitrary files.

Basic Data

PublishedMarch 26, 2001
Last ModifiedOctober 10, 2017
Assignercve@mitre.org
Data TypeCVE
Data FormatMITRE
Data Version4.0
Problem TypeNVD-CWE-Other
CVE Data Version4.0

Base Metric V2

CVSS 2 - Version2.0
CVSS 2 - Vector StringAV:L/AC:L/Au:N/C:P/I:N/A:N
CVSS 2 - Access VectorLOCAL
CVSS 2 - Access ComplexityLOW
CVSS 2 - AuthenticationNONE
CVSS 2 - Confidentiality ImpactPARTIAL
CVSS 2 - Availability ImpactNONE
CVSS 2 - Base Score2.1
SeverityLOW
Exploitability Score3.9
Impact Score2.9
Obtain All Privilegefalse
Obtain User Privilegefalse
Obtain Other Privilegefalse

Base Metric V3

No data provided.

Configurations

  • OR - Configuration 1
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3ApplicationImmunixImmunix7.0_beta*******
    2.3OSConectivaLinux4.0*******
    2.3OSConectivaLinux4.0es*******
    2.3OSConectivaLinux4.1*******
    2.3OSConectivaLinux4.2*******
    2.3OSConectivaLinux5.0*******
    2.3OSConectivaLinux5.1*******
    2.3OSConectivaLinux6.0*******
    2.3OSConectivaLinuxecommerce*******
    2.3OSConectivaLinuxgraficas*******
  • OR - Configuration 2
    Cpe VersionPartVendorProductVersionUpdateEditionLanguageSW EditionTarget SWTarget HWOtherVersion Start IncludingVersion End IncludingVersion Start ExcludingVersion End Excluding
    2.3OSDebianDebian Linux2.3*******
    2.3OSRedhatLinux7.0*alpha*****
    2.3OSRedhatLinux7.0*i386*****

Vulnerable Software List

VendorProductVersions
Immunix Immunix 7.0_beta
Debian Debian Linux 2.3
Redhat Linux 7.0
Conectiva Linux 4.0, 4.0es, 4.1, 4.2, 5.0, 5.1, 6.0, ecommerce, graficas

References

NameSourceURLTags
20010110 Glibc Local Root Exploithttp://archives.neohapsis.com/archives/bugtraq/2001-01/0131.htmlBUGTRAQVendor Advisory
20010110 [slackware-security] glibc 2.2 local vulnerability on setuid binarieshttp://archives.neohapsis.com/archives/bugtraq/2001-01/0186.htmlBUGTRAQPATCH Vendor Advisory
RHSA-2001:001http://www.redhat.com/support/errata/RHSA-2001-001.htmlREDHATPATCH Vendor Advisory
2181http://www.securityfocus.com/bid/2181BIDPATCH Vendor Advisory
linux-glibc-read-files(5907)https://exchange.xforce.ibmcloud.com/vulnerabilities/5907XF